Mapmaker

From the Mapmaker, you can add, edit, or remove objects, tiles effects, walls, and floors, as well as add and remove Rooms. For an video overview of the Mapmaker tool, check out our YouTube tutorial:

This article covers who can use the Mapmaker, how to open it, and a high-level overview of the tools that are available in it. Additional articles in the Space Design section provide full details on the tools and features available for customizing your Space.

Who Can Use the Mapmaker

If you want to allow someone to customize the Space using the Mapmaker, they must be added as a Builder or Owner. Open Settings and select User Roles in the Space tab. Enter the user's email address under the desired role and select Add.

A screenshot of the Settings modal with the Space tab open and User Roles selected. The Settings icon, Space tab, and User Roles section are outlined in red. The User Roles options visible include Owners and Moderators. Each role has a field to enter an email address, with an Add button. Any currently listed users under a role have a Remove button next to their email.To add a Builder or Owner, select Settings in the Left Nav Menu. Select the Space tab and select User Roles. Under Owners or Moderators, enter the person's email address and select Add.

Warning: Only one person should be editing the Mapmaker at a time. If multiple people are editing the Mapmaker at the same time and someone selects Save, changes can be overwritten.

How to Open the Mapmaker

To access the Mapmaker while in your Space, select Build in the Left Nav Menu, then select Edit in Mapmaker. The Mapmaker opens in a new tab.

A screenshot of the fancy office template with the Build panel open. The Build tool (hammer icon) is outlined in red in the Left Nav Menu, and the Edit in Mapmaker button is outlined in red in the Build panel.To open the Mapmaker from your Space, select Build in the Left Nav Menu, then select Edit in Mapmaker.

You can also access the Mapmaker from your Gather home page (https://gather.town/app). Select the ellipses in the bottom right corner of the Space preview. Select Edit Map. The Mapmaker opens (in the same tab).

A view of the Gather home page. The Spaces tab is active, and one Space preview shows on the Last Visited tab. Beneath the Space preview, the ellipses button is selected and a small menu displays with the options to Manage Space, Edit Map, or Copy URL. Manage Space is highlighted.From your Gather home page, select the ellipses beneath the Space preview. Select Edit Map to open Mapmaker.

The Mapmaker has two navigation menus and a right-hand panel that let you edit your Space. The Top Nav Menu allows you to select which aspect of the Map you wish to edit: objects, tile effects, or walls and floors. The Left Nav Menu provides the tools for manipulating your Map. 

Top Nav Menu Tools

From the Top Nav Menu, select the aspect of the Map you wish to edit (Objects, Tile Effects, or Walls & Floors). You can also view additional options in the hamburger menu, save your changes, view the name of the Space you're editing, and add a Builder to the Space.

Hamburger Menu

Select the hamburger menu in the top left corner of the Mapmaker to access the following options:

  • Go to Space: Return to the Space you are editing
  • Manage Space: Open the Space's dashboard
  • Guides and Tutorials: Open the help center
  • Background & Foreground: Upload or download a background or foreground
  • Extension Settings: Manage extensions (e.g., doors, friendly plants)

A screenshot of the fancy office template in Mapmaker. The hamburger menu in the top left corner is selected, and two drop-down menus display. The first menu shows Go to Space, Manage Space, Guides and Tutorials, Background & Foreground, and Extension Settings. The Background & Foreground option is selected, and the second drop-down shows Upload Background, Upload Foreground, Download Background, and Download Foreground. The menus are outlined in red.Select the hamburger menu in the Mapmaker to return to your Space, go to the Space dashboard, open the help center, upload/download your background or foreground, and manage extensions. The Top Nav Menu lets you manage Objects, Tile Effects, and Walls & Floors, as well as saving and adding Builders.

Objects

Select Objects in the Top Nav Menu to move, place, edit, or delete objects in the Map. When Objects is selected, the right panel in the Mapmaker provides access to Objects and Object details. The Objects tab shows recently added or our suggested objects. Select More Objects to open the Object Picker. 

A screenshot of the conference room in the top left of the fancy office template. Objects is selected and outlined in red in the Top nav and the Select tool is active. In the right panel, the Objects tab is outlined in red. When Objects is selected in the Top Nav Menu of the Mapmaker, you can manage any object in the Map. The right panel provides a preview of recently used objects. Select More Objects to open the Object Picker The Object details tab in the right panel allows you to edit the object, including changing its colors or adding interaction in Advanced options.

After you select an object from the Object Picker in our Mapmaker, you can easily rotate and change the color of the object before placing it. You can rotate the object by:

  • Selecting the arrow keys on either side of the object in the Object details section of the right panel
  • Pressing the key on your keyboard to rotate clockwise
  • Pressing shift+R on your keyboard to rotate counter-clockwise

Note: For more info on the Object Picker and the Advanced options available, see the Objects articles.

A screenshot of the conference room in the top left of the fancy office template. Objects is selected and outlined in red in the Top nav and the Select tool is active. In the right panel, the Objects details is outlined in red, and Advanced options is outlined in red beneath the different color options for Succulent (Colorata). . The right panel also provides access to Object details. You can change the color of the object (if multiple colors are available) and set Advanced options to create interactive objects.

Tile Effects

Select Tile Effects in the Top Nav Menu to move, place, edit, or delete effects applied to tiles in the Map. When Tile Effects is selected, all tile effects are visible, and the following tile effects are available for selection in the right panel:

  • Impassable: Prevent people from walking through the tile, which is handy for walls and furniture. Impassable effects are indicated by red semi-transparency.
  • Spawn: Select where people will appear when joining the Space. Spawn effects are indicated by green semi-transparency.
  • Portal: Create an entrance or exit to another Room, Space, or tile on the Map. Portal effects are indicated by blue semi-transparency.
  • Private Area: Restrict audio and video connections to other users in the same area. Private area effects are indicated by pink semi-transparency. 
  • Spotlight: Allow a person to broadcast their audio, video, and screen to everyone in the Room, up to 100 people. Spotlight effects are indicated by orange semi-transparency. 

Note: You must select the tile effect in the Tile Effects tab in the right panel to see all tiles with that effect applied. Tiles can have multiple effects applied. For full details about tile effects, see the Tile Effects articles.

A screenshot of the conference room in the top left of the fancy office template. Tile Effects is selected and outlined in red in the Top nav and the Select tool is active. In the right panel, the Tile Effects tab is outlined in red. Impassable, Spawn, Portal, and Private Area tile effects are visible. The mapmaker shows all the red impassable tile because Impassable is active in the Tile Effects panel. When Tiles Effects  is selected in the Top Nav Menu of the Mapmaker, you can manage any tile effects in the Map. The right panel provides a list of available effects. Select the tile effect to see all tiles with that effect applied.  

Walls & Floors

Select Walls & Floors in the Top Nav Menu to move, place, edit, or delete walls and floors in the Map. When you select Walls & Floors, a warning displays: "Placing Walls & Floors will remove any currently uploaded background image." 

A screenshot of the conference room in the top left of the fancy office template. Walls & Floors Beta is selected and outlined in red in the Top nav, with a red arrow pointing to the warning message.When you select Walls & Floors, a warning message displays. Select Continue to proceed to the Background Painter tool.  You must select Continue to proceed. The Background Painter opens. A new Top Nav Menu and right panel display, and the background image is removed. Select Walls to place walls in your Map, and select Floors to place floors. Available options for walls or floors display in the right panel. 

After placing your desired walls or floors,  select Done. If you do not want to make changes to the walls or floors, select Cancel.

Note: For full details on how to use the Background Painter, see the Background and Foreground articles.

A view of the background painter tool in the mapmaker. The floors and walls that were previously visible are gone, and only the objects and tile effects display. The right panel shows six different wall options.Select Walls or Floors in the Top Nav Menu to use the Background Painter tool. Available options for walls or floors display in the right panel.

Left Nav Menu Tools

Select Tool

Use the Select tool (keyboard shortcut = V) to individually manipulate objects or tile effects. 

When you select an object or tile, you can edit details of that object or tile. You can select List of objects to view the order of objects on that tile and the effects applied to the tile. You can reorder the objects by selecting the reorder icon (two lines) and dragging the object to its desired order. If you select the ellipses on an object, you can also manipulate the order of the object and duplicate or delete the object.

A screenshot of the conference room in the top left of the fancy office template. Objects is selected in the Top nav and the Select tool is active. A white box displays around the succulent on the table top. A red arrow points from the List of objects tab in the right panel to the selected succulent. In the List of objects tab, the ellipses next to Succulent (Colorata) is selected, and a drop-down menu shows Bring forward, Send to back, Move up, Move down, Duplicate, and Delete. To view all objects and tile effects on a given tile, select the tile and view the List of objects tab in the right panel. You can then reorder the objects by dragging them or by selecting the ellipses.

Stamp Tool

Use the Stamp tool (keyboard shortcut = B) to add objects or tile effects. To add objects, select Objects in the Top Nav Menu, then find the object you wish to add in the right panel or Object Picker, and click on the tile where you want it to appear.  To add tile effects, select Tile Effects, choose the desired tile effect in the right panel, and click on the tile(s) you wish to apply the effect to.

Erase Tool

Use the Erase tool (keyboard shortcut = E) to remove objects or tile effects. To remove objects, select Objects in the Top Nav Menu, then click on the object you wish to remove. (Objects are erased from top to bottom in the stack.) To remove tile effects, select Tile Effects, choose the type of effect you wish to remove in the right panel, then click on the tile(s) you wish to remove the effect from. 

Hand Tool

Use the Hand tool (keyboard shortcut = H) to pan around the Map without using the scroll bars. Just click and drag to move to the desired location on the Map.

Zoom Tools

Use the Zoom In tool (keyboard shortcut = Ctrl/⌘ + scroll up) to zoom in on the Map. Use the Zoom Out tool (keyboard shortcut = Ctrl/⌘ + scroll down) to zoom out on the Map.

Undo/Redo

Use the Undo tool (keyboard shortcut = Ctrl/⌘ + Z) to undo your change. Use the Redo tool (keyboard shortcut = Ctrl/⌘ + Shift + Z) to reapply the change you undid.

Tip: Remember to select Save before trying to view your changes. When you're ready to see your changes, return to your Space on the original browser tab or use the hamburger menu and select Go to Space.